05 STS P0430 (bank 2 cat efficiency)

It's your engine, transmission, driveline
kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Tue Jul 23, 2019 5:48 am

Jamie borrowed the STS on Saturday. When I started it on Sunday, the light was on. Reset. I think the light came on again Monday, maybe in the afternoon. Reset after getting gas. Just came on again this morning on my way in. Reset while driving. That is a lot of activity...

Thinking about looking into rear O2 simulators again. If it actually works I may just do that.

kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Fri Aug 16, 2019 5:40 pm

Light went off yesterday on its own. I forgot when it came on. At least Tuesday. Was it before vacation? Maybe...

kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Tue Sep 03, 2019 6:35 am

Getting tired of tracking this...light came on like...over the weekend maybe. Reset. It came on with the very next ignition cycle (which was a warm start).

It would be nice if someone has tried a rear O2 simulator on the 05 ECM and had success. Maybe it doesn't really need to be super tuned to the particular ECM, since there are really only two main strategies of determining catalyst efficiency. And even though the 05 ECM is that bespoke GM/Siemens effort, I'd think the cat efficiency approach would be similar to previous (or future) approaches.

kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Tue Sep 24, 2019 4:52 pm

Came on. Reset. That was longer than expected.

kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Sun Oct 06, 2019 1:33 pm

Came on. Reset.

kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Fri Oct 11, 2019 5:29 pm

Came on. Reset.

kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Wed Oct 16, 2019 3:28 pm

Came on...reset.

kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Sun Oct 20, 2019 2:04 pm

Came on. Reset.

kevm14
Posts: 13935
Joined: Wed Oct 23, 2013 10:28 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by kevm14 » Thu Nov 14, 2019 2:32 pm

So the last few times I have let the light come on and then just wait to see how long it takes to go out again. It is reliably coming on, and then after some ignition cycles and drive time, goes out. It will only go out upon a new ignition cycle. But what this means it that the cat is still capable of passing the test. Just not all the time...

It seems to only come on while driving and usually within the first 2 minutes of the ignition cycle. Warm restarts seem to trigger it more often. Still no plans to fix this.

Adam
Posts: 2179
Joined: Wed Oct 23, 2013 9:50 pm

Re: 05 STS P0430 (bank 2 cat efficiency)

Post by Adam » Sun Nov 17, 2019 5:14 pm

When does the inspection expire?

Post Reply