01 325Ci Lean/Misfire Codes

It's your engine, transmission, driveline
Post Reply
Adam
Posts: 2179
Joined: Wed Oct 23, 2013 9:50 pm

01 325Ci Lean/Misfire Codes

Post by Adam » Tue Apr 30, 2019 7:38 pm

Now trying to fix the additional issues encountered at the end of the Cam Sensor thread. According to the internet, lean codes on this car are caused by vacuum leaks. The only thing I haven't replaced that can cause vacuum leaks is the valve cover gasket. Also, seeing as the engine has nearly 100k on it, I'm going to do the plugs and coil boots as well.

I didn't take many pics of the disassembly. Most of that is covered in the "All the Maintenance" thread. After you remove the cabin air filter housing and engine covers, you see the coil packs.
20190427_153017.jpg
The coils use a fancy metal clip to attach the harness to. You pull it up, then you can slide the plug out. The coils share a ground plate that it tied to the cylinder head with braided straps at either end. Plenty of conductivity. If only the tail light harnesses were as well made...
20190427_153022.jpg
Pulled the first coil, found some oil. Looks like I've located the vacuum leak. Fortunetely there was only oil in plug tube #1.
20190427_153101.jpg
Once the coils are out of the way, you can pull the plugs. They were definitely worn out. Does the plug design look familiar? You'll never guess the brand. It's NGK. The OEM plugs also say BMW on them in addition to NGK.
20190427_155319.jpg
20190427_155324.jpg
Now time for the valve cover. It comes right off after removing many bolts. Notice the cover on the intake cam. Probably for oil control? It's made of plastic.
20190427_162933_HDR.jpg
The gasket was in terrible condition. Imagine old brittle plastic, then thinl about how a rubber gasket becomes like that over time. Then imagine installing something like that in the "Ultimate Driving Machine". Removing the old gasket was definitly the longest part of this whole job. There was a little oil sludge inside the valve cover. I cleaned it up (not pictured). The new gasket goes right in. Fun fact, breaking the plasitc valve cover is a thing on these cars, it usually happens when you are fighting with the old gasket to remove it.
20190427_165422.jpg
Anyway, reassembly is the reverse of removal. I reset the codes and have now driven 6 driving cycles w/o issues. Fixed forever? It'll be interesting to see if the fuel economy improves with much less worn plugs. Hot starts take ~1 less rotation of the engine as well, whatever that's worth.

On to the next thing?

Post Reply